Australian Land Rover Owners

Gallery Donate Games Arcade Calendar Markets Shop Chat Subscribe! Files Links
Go Back   Australian Land Rover Owners > The Pinnacles > Discovery > D3 / D4 / RRS


D3 / D4 / RRS D3 / D4 zone is the place for all that specialist D3 / D4 info (and the RRS stuff even though they don't like to think of it as a disco).

Reply
 
Thread Tools Display Modes
  #1 (permalink)  
Old 18th October 2010, 11:52 AM
DiscoWeb's Avatar
Master
Subscriber
 
Join Date: Oct 2009
Location: St George Dragons Territory, NSW
Posts: 745
Thanks: 162
Thanked 375 Times in 235 Posts
SUSPENSION SQUEAKS

Over the weekend as I was doing some running around with the window down and I noticed a real squeak from my suspension as I went over speed bumps, into and out of driveways etc.

It was fairly intermittent, however as I has done less than 40K and I am aware of suspension bushes, ball joints etc been a potential problem I though I would seek some feedback from those with much greater technical knowledge than I posses.

It is a 2009 TDV6 SE, any thoughts, should I get it seen to straight away or wait until next service in a couple of months.

It is not annoying enough to be a bother an only noticeable at slow speed with with the windows down. I have not noticed any play in steering or change in handling so for what it is worth.

Regards,

George
__________________
************************************
Discoweb

2009 D3, Silver, TDV6 SE, e-diff, rock sliders, OL Bar, winch, GME UHF, Foxwing and Bridgestone D697 LT
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 18th October 2010, 07:59 PM
Disco4SE's Avatar
Wizard
 
Join Date: Feb 2010
Location: Mount Martha
Posts: 1,264
Thanks: 4
Thanked 390 Times in 239 Posts
Quote:
Originally Posted by DiscoWeb View Post
Over the weekend as I was doing some running around with the window down and I noticed a real squeak from my suspension as I went over speed bumps, into and out of driveways etc.

It was fairly intermittent, however as I has done less than 40K and I am aware of suspension bushes, ball joints etc been a potential problem I though I would seek some feedback from those with much greater technical knowledge than I posses.

It is a 2009 TDV6 SE, any thoughts, should I get it seen to straight away or wait until next service in a couple of months.

It is not annoying enough to be a bother an only noticeable at slow speed with with the windows down. I have not noticed any play in steering or change in handling so for what it is worth.

Regards,

George
Hi George,
This was response in another thread........Hi Kev,
Believe it or not, mine had the squeaky suspension as well. Had to have the front drivers side shocker replaced, then the front stabilizer bar bushes. Apparently the bushes in these aren't too good, so they replace them with better ones.
No more squeaks now but still have the shuddering mirror.
Cheers, Craig
Reply With Quote
  #3 (permalink)  
Old 18th October 2010, 08:04 PM
Scouse's Avatar
Administrator
 
Join Date: Jan 1970
Location: Douglas Park, NSW
Posts: 8,213
Thanks: 1,281
Thanked 2,167 Times in 1,696 Posts
Squeaks are usually down to dry sway bar bushes.
Movement in the bushes usually results in a knock but if you just have a squeak, then chances are they're just dry (or full of Lithgow mud ).
__________________
Scott

1995 Range Rover HSE
1996 Range Rover HSE
1998 Range Rover DSE
Reply With Quote
  #4 (permalink)  
Old 18th October 2010, 09:04 PM
richard4u2's Avatar
Wizard
 
Join Date: May 2009
Location: perth w.a.
Posts: 1,209
Thanks: 323
Thanked 245 Times in 196 Posts
i maybe just dust in the bushes give it a good hit with a high pressure water hose and see if that helps
Reply With Quote
Sponsored Links
  #5 (permalink)  
Old 18th October 2010, 11:25 PM
ChatterBox
 
Join Date: Mar 2008
Location: Sydney, Australia
Posts: 2,357
Thanks: 158
Thanked 473 Times in 390 Posts
Silicone spray?
Reply With Quote
  #6 (permalink)  
Old 19th October 2010, 05:06 AM
Disco4SE's Avatar
Wizard
 
Join Date: Feb 2010
Location: Mount Martha
Posts: 1,264
Thanks: 4
Thanked 390 Times in 239 Posts
Hi again George,
I almost guarantee that it will be the front stabilizer bushes. I was told that this was a common fault because the originals are poor quality. The new ones are supposed to be a big improvement and shouldn't wear any where near as quick.
My D4 is also a 2009 TDV6 SE.
Let me know how you go.
Regards, Craig
Reply With Quote
  #7 (permalink)  
Old 19th October 2010, 07:51 AM
DiscoWeb's Avatar
Master
Subscriber
 
Join Date: Oct 2009
Location: St George Dragons Territory, NSW
Posts: 745
Thanks: 162
Thanked 375 Times in 235 Posts
Thanks for the replies,

I did not think it was anything to drastic and as Scouse mentioned might have a bit of mud and dirt in there, that Newnes mud hole strikes again.

I will get it looked into at the next service and have a crack a lubricating and cleaning in the mean time.

Regards,

George
__________________
************************************
Discoweb

2009 D3, Silver, TDV6 SE, e-diff, rock sliders, OL Bar, winch, GME UHF, Foxwing and Bridgestone D697 LT
Reply With Quote
  #8 (permalink)  
Old 19th October 2010, 01:21 PM
Wizard
 
Join Date: May 2010
Location: Brisbane, QLD, Australia
Posts: 1,589
Thanks: 496
Thanked 321 Times in 206 Posts
Quote:
Originally Posted by DiscoWeb View Post
Thanks for the replies,

I did not think it was anything to drastic and as Scouse mentioned might have a bit of mud and dirt in there, that Newnes mud hole strikes again.

I will get it looked into at the next service and have a crack a lubricating and cleaning in the mean time.

Regards,

George
Hey George,

I've got a 2009 SE TDV6 also.

Yup, I've asked about this in an earlier thread and got feedback from dead shocks to just the need for lube.

I've just built a new house and work has been flat out, so as the car was driving fine, I haven't got off my arse to do anything about it as yet.

Sounds like LR will have something to do when mine goes in at the end of the month.

Cheers.

Kev.
Reply With Quote
  #9 (permalink)  
Old 23rd October 2010, 02:09 PM
Dorko's Avatar
Master
 
Join Date: Sep 2008
Location: Perth
Posts: 511
Thanks: 74
Thanked 64 Times in 40 Posts
My suspensions make the squeak noise too. Took it into LR and they said it was just heaps of mud and dirt.

They washed it out and its better, but still the noise is slightly there when you are offroad. LR said there is no problem just part of a 4WD.

Dorko
Reply With Quote
  #10 (permalink)  
Old 23rd October 2010, 11:45 PM
Leo Leo is offline
Master
 
Join Date: Apr 2008
Location: Kenya
Posts: 224
Thanks: 138
Thanked 46 Times in 26 Posts
Had squeaky bushes once - was waiting for dealer to get spares, then one day the squeaking stopped on its own! Sometimes I think the car's alive, lol. Got to love Land Rovers!
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Search AULRO.com ONLY!
Search All the Web!

All times are GMT +10. The time now is 08:15 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
Live Threads provided by AJAX Threads v1.1.2 (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Australian Land Rover Owners
Copyright 2001 - 2014, Dave Blears Computing - DavecandoIT and aulro.com