Australian Land Rover Owners

Gallery Donate Games Arcade Calendar Markets Shop Chat Subscribe! Files Links
Go Back   Australian Land Rover Owners > The Pinnacles > Discovery > D3 / D4 / RRS


D3 / D4 / RRS D3 / D4 zone is the place for all that specialist D3 / D4 info (and the RRS stuff even though they don't like to think of it as a disco).

Reply
 
Thread Tools Display Modes
  #1 (permalink)  
Old 12th November 2012, 12:56 PM
Member
 
Join Date: Nov 2012
Location: Melbourne
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Angry D3 faulty fuel gauge

Hi there, I'm travelling through Queensland on my trip around Australia (I left Melbourne 7 weeks ago). My problem is my fuel gauge has stopped working and showing empty all the time. Any tips on what I could check to fix or diagnose it? Before I have to pay a land rover specilist big bucks to fix it for me?

Cheers.
Reply With Quote
Sponsored Links
  #2 (permalink)  
Old 12th November 2012, 01:10 PM
weeds's Avatar
OldBushie
 
Join Date: Feb 2005
Location: Bracken Ridge - Brisbane - QLD
Posts: 9,698
Thanks: 2,793
Thanked 2,116 Times in 1,433 Posts
can you see where the wires connect to the sendor at the tank?

if so i assume you have checked that a wire isn't loose?

other than that i am not much help......it would be a pain having to use the trip meter for the entire trip
Reply With Quote
  #3 (permalink)  
Old 12th November 2012, 01:54 PM
weakestlink's Avatar
Master
 
Join Date: Feb 2010
Location: Melbourne
Posts: 564
Thanks: 359
Thanked 163 Times in 128 Posts
Quote:
Originally Posted by Gaultandrew View Post
Hi there, I'm travelling through Queensland on my trip around Australia (I left Melbourne 7 weeks ago). My problem is my fuel gauge has stopped working and showing empty all the time. Any tips on what I could check to fix or diagnose it? Before I have to pay a land rover specilist big bucks to fix it for me?

Cheers.
Go to a auto sparky if you cannot find the loose wires yourself might be an idea.
Reply With Quote
  #4 (permalink)  
Old 12th November 2012, 02:30 PM
BigJon's Avatar
ForumSage
Subscriber
 
Join Date: Jan 1970
Location: Adelaide - Torrens Park
Posts: 6,699
Thanks: 2,051
Thanked 1,118 Times in 834 Posts
IIRC these were a common issue when new. Perhaps Sniegy will know.
__________________
(76 Two Door - Unmolested)
(88 Hiline - Now with Limited Slip rear diff)
(07 Vogue TDV8 )
Reply With Quote
Sponsored Links
  #5 (permalink)  
Old 12th November 2012, 05:14 PM
Member
 
Join Date: Nov 2012
Location: Melbourne
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Hi, I can't even find the sender unit in the tank. Does anyone have an idea where it is?
Reply With Quote
  #6 (permalink)  
Old 12th November 2012, 07:20 PM
sniegy's Avatar
ChatterBox
Gold Subscriber
 
Join Date: Jan 1970
Location: Melbourne
Posts: 2,436
Thanks: 644
Thanked 1,249 Times in 736 Posts
The sender units (there are 2) are located inside the tank.

There were a few issues on early vehicles & from memory if it is a petrol version there wad a recall.
Get in touch with your local dealer, supply last 6 digits of your VIN & we/they can advise if you have an outstanding action against your vehicle.
Otherwise you need to take resistive readings from the connector behind the r/h/f wheel arch as there is a big connector in there & these readings will tell which sender is faulty.
Problem is if it is the rear sender in the tank, you can't replace it as you can't get to it & you will have to replace the tank..

Cheers

Sent from my iPad using Forum Runner
__________________
Ex 89 RR Classic V8i, Ex 93 D1 200Tdi, Ex 97 D1 300Tdi, Ex 98 D1 V8i LS, Ex 01 D2 Td5
D4 2.7 TDV6 in Alaska White / Almond/Arabica, E-Diff, 7 Leather Seats, Rear A/C, Sunroof & Bi-Xenons with LED Signature !
To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.


Keep Smilin'
To view links or images in signatures your post count must be 1 or greater. You currently have 0 posts.
Pete.
Reply With Quote
The Following User Says Thank You to sniegy For This Useful Post:
BigJon (13th November 2012)
  #7 (permalink)  
Old 12th November 2012, 07:47 PM
weakestlink's Avatar
Master
 
Join Date: Feb 2010
Location: Melbourne
Posts: 564
Thanks: 359
Thanked 163 Times in 128 Posts
Quote:
Originally Posted by Gaultandrew View Post
Hi, I can't even find the sender unit in the tank. Does anyone have an idea where it is?
On top. You would need to drop the tank to get get to it I think. I just shoved my head under mine and cannot see. It didn't look to much to drop the fuel tank. Would be easier to do when empty which is a pain given your not at home.
Reply With Quote
  #8 (permalink)  
Old 12th November 2012, 07:53 PM
SBD4's Avatar
Wizard
Gold Subscriber
 
Join Date: Dec 2011
Location: Bundeena, NSW, Aust
Posts: 1,078
Thanks: 2,026
Thanked 611 Times in 390 Posts
these may help you:

Discovery 3 v8 petrol gauge keep showing empty - FixYa
DISCO3.CO.UK - View topic - Fuel Gauge shows empty!!
__________________
Cheers,

Sean
MY10 D4 TDV6 3.0 HSE Baltic Blue
Reply With Quote
The Following User Says Thank You to SBD4 For This Useful Post:
weakestlink (13th November 2012)
  #9 (permalink)  
Old 13th November 2012, 09:47 AM
weakestlink's Avatar
Master
 
Join Date: Feb 2010
Location: Melbourne
Posts: 564
Thanks: 359
Thanked 163 Times in 128 Posts

SBD4's links picture shows the location and why we cannot get to it with out removing the car or the tank
Reply With Quote
  #10 (permalink)  
Old 13th November 2012, 09:52 AM
weakestlink's Avatar
Master
 
Join Date: Feb 2010
Location: Melbourne
Posts: 564
Thanks: 359
Thanked 163 Times in 128 Posts
Not certain but look at this link. It is not a Disco 3! I will edit after lifting my carpet to see it I have access to the sender unit as this link suggests. If so it look a fairly straight forward job.

How To Change the Fuel Tank Breather/Vent Hose - Land Rover Forums - Land Rover Enthusiast Forum

In the RHS footwell of the 3rd row of seat there appears to be an access point. I did not rip all my carpets out of mine just lifted a corner. Fairly sure the link above will help with out removing your tank to access the sender. I would still get a sparky as you may be better off testing the wiring properly.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



Search AULRO.com ONLY!
Search All the Web!

All times are GMT +10. The time now is 03:27 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.0 PL2
Live Threads provided by AJAX Threads v1.1.2 (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Australian Land Rover Owners
Copyright 2001 - 2014, Dave Blears Computing - DavecandoIT and aulro.com