Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: Loud squealing when applying Brakes on my Defender

  1. #21
    Join Date
    Jun 2013
    Location
    Brisbane Area
    Posts
    891

    Question

    Anybody tried this stuff made by CRC?IMG_5029.jpg

    Curious to know if this stuff will work in quietening the squeaky brakes?
    Cheers.....
    Rob M

    =============
    Car-1: 1996 Discovery Tdi Auto
    Car-2: 1995 Defender Tdi Wgn
    Car-3: 2010 Toyota Prado 150's
    My completed TRIPS: Rob's WikiLoc Trips or Rob's AllTrails Trips

  2. #22
    Join Date
    Feb 2005
    Location
    Bracken Ridge - Brisbane - QLD
    Posts
    11,963
    I have found OEM pads to be squeal free......ensuring you install as per instructions.

    2000 110 Hardtop

  3. #23
    Join Date
    Jun 2013
    Location
    Brisbane Area
    Posts
    891

    Question

    Quote Originally Posted by weeds View Post
    I have found OEM pads to be squeal free......ensuring you install as per instructions.
    I assume that's with the Shims and springs for the pins, etc ???

    Rough idea of the $$ for OEM pads ??
    Cheers.....
    Rob M

    =============
    Car-1: 1996 Discovery Tdi Auto
    Car-2: 1995 Defender Tdi Wgn
    Car-3: 2010 Toyota Prado 150's
    My completed TRIPS: Rob's WikiLoc Trips or Rob's AllTrails Trips

  4. #24
    Join Date
    Feb 2005
    Location
    Bracken Ridge - Brisbane - QLD
    Posts
    11,963
    Quote Originally Posted by Robmacca View Post
    I assume that's with the Shims and springs for the pins, etc ???

    Rough idea of the $$ for OEM pads ??
    Yep, no idea what I paid as it was a while ago, I do remember I purchased from MR

    2000 110 Hardtop

  5. #25
    Join Date
    Sep 2009
    Location
    Surry Hills Sydney
    Posts
    106
    Im willing to bet your disks are glazed. I put new pads with CRC silicone pad glue in mine and they still squealed.
    A sanding disk on my drill fixed the problem.
    TD5 Defender-Auto conversion

  6. #26
    Join Date
    Jun 2013
    Location
    Brisbane Area
    Posts
    891
    Quote Originally Posted by timax View Post
    Im willing to bet your disks are glazed. I put new pads with CRC silicone pad glue in mine and they still squealed.
    A sanding disk on my drill fixed the problem.
    Yeah already did the sanding disc thing but it only worked temporarily. The discs are still new.
    Hoping the CRC might have been a solution, but a different pad might have to the solution in the end
    Cheers.....
    Rob M

    =============
    Car-1: 1996 Discovery Tdi Auto
    Car-2: 1995 Defender Tdi Wgn
    Car-3: 2010 Toyota Prado 150's
    My completed TRIPS: Rob's WikiLoc Trips or Rob's AllTrails Trips

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!