Results 1 to 5 of 5

Thread: Drivers Side Power Window Clunk 2008 Puma

  1. #1
    Join Date
    Jan 1970
    Location
    Melrose Park NSW
    Posts
    1,526

    Drivers Side Power Window Clunk 2008 Puma

    There is a loud clunk when operating the drivers side power window in my Puma. Usually when it about 3/4 the way up. Any ideas on what this may be and has anyone else had the problem. Also what is the fix.

    All information would be greatly accepted.

    Thanks
    Chenz
    I do not wish to be a member of any club that would have me as a member

    Former Owner of The Red Terror - 1992 Defender 200Tdi
    Edjitmobile - 2008 130 Defender

  2. #2
    Join Date
    Oct 2013
    Location
    East Kurrajong, NSW
    Posts
    1,402
    Same in our 2012 90, both sides but not every time. Be interested to see what others thinkÖ
    Cheers
    Travelrover

    Adventure before Dementia

    2012 Puma 90 - Black
    1999 Td5 110 Ute - White
    1996 Tdi 300 Wagon - White (the project)
    1977 Series III 88" Petrol (the other project)

    VKS-737 - Mobile 0972

  3. #3
    tieds is offline Fossicker Gold Subscriber
    Join Date
    Apr 2010
    Location
    sydney
    Posts
    43

    Power window clunk

    Quote Originally Posted by Chenz View Post
    There is a loud clunk when operating the drivers side power window in my Puma. Usually when it about 3/4 the way up. Any ideas on what this may be and has anyone else had the problem. Also what is the fix.

    All information would be greatly accepted.

    Thanks
    Hi,
    ĎIíve had my doors apart several times for installing soundproofing, tightening the ever loosening door handle screw and an annoying rattle. Iíve found the rattle was due to the rear window channel locating screw at the bottom was loose. It sits inside the channel and attaches it to the door structure and if you replace it with a larger screw in order to be more secure the head of the screw can foul the window as it descends and a clunking scrunching noise can result. After filing and grinding the screw head to lower its profile but still retain enough base for the screw driver to grab Iíve reduced the problem but not solved it. Iím sure Land Rover could have devised a better system but itís not surprising. Bear in mind this all happens as the window is close to the bottom of itís travel so may not apply to your problem, worth a look thoughÖ.
    my two bobs worth,
    regards

  4. #4
    MLD's Avatar
    MLD is offline Wizard Silver Subscriber
    Join Date
    Aug 2011
    Location
    Stanwell Park, NSW
    Posts
    1,452
    could be caused by several sources. I lost normal function of my window (MY11). when I pulled the motorised scissor mechanism out several things had failed. First the pin that holds the 2 scissor mechanisms together and is the pivot for the scissor had sheared but not completely dislodged. there was enough engagement with the motor gear to lift the window most of the way but it would go skew-if when the mechanism put too much pressure on the sheared pin with mechanism separating. I also found the bolts holding the mechanism to the door were finger tight and a few other attachment points not as secure as you would like. I suspect when the pin went it had a knock effect. Long and short, replacing the entire window lifting mechanism is one of the easiest repairs I've done to the Defer. Watch the Youtube vids and it's really straight forward. They are no expensive from memory.

    answering your Q, to me it sounds like the 2 stage mechanism when it shifts from the first stage to the second stage there is something jamming. as above the pin is central to it all working smoothly. The arms cross over each other which is ripe for a stick or a bent arm catching the other arms.
    MLD

    Current: (Diggy) MY10 D130 ute, locked F&R, long travel suspension and rolling on 35's.
    Current: (Steed) MY11 Audi RS5 phantom black (no need for mods as it left the factory touched by God himself)
    Gone: (Dorothy) MY99 TD5 D110

  5. #5
    tieds is offline Fossicker Gold Subscriber
    Join Date
    Apr 2010
    Location
    sydney
    Posts
    43
    Quote Originally Posted by Chenz View Post
    There is a loud clunk when operating the drivers side power window in my Puma. Usually when it about 3/4 the way up. Any ideas on what this may be and has anyone else had the problem. Also what is the fix.

    All information would be greatly accepted.

    Thanks
    Another possibility is that one or both of the cradles attached to the scissor mechanism that raises and lowers the window have come loose. Iíve reattached these with polyurethane glue/cement.
    regards

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!