Results 1 to 4 of 4

Thread: 07 Ford Ranger Oil leak

  1. #1
    Join Date
    Aug 2012
    Location
    Adelaide
    Posts
    2,757
    Total Downloaded
    0

    Question 07 Ford Ranger Oil leak

    Hi Guys,

    I was servicing my 07 Ford Ranger 3L turbo Diesel the other day and found what I thought was the oil return hose (from the turbo) leaking! It had oil all over it... sorta looked like it was the culprit. Bought a $35 new hose from Ford - yes genuine.... noone else seemed to have one.

    That was Wednesday last week, I've done about 300kms since. I stuck my head under there today and my new hose is all covered in oil!! I havn't fixed anything by the look of it, just purchased a very expensive hose....

    Does anyone have any experience with these things? Could you please share you opinions/ideas/suggestions? And before you all say "sell it and buy a defender" I dont have the money for that

    Thanks

  2. #2
    Join Date
    Aug 2012
    Location
    Adelaide
    Posts
    2,757
    Total Downloaded
    0
    Surely someone has seen this before.... come on guys lend me a hand! Please.

  3. #3
    Join Date
    Mar 2008
    Location
    Gone walkabout
    Posts
    2,322
    Total Downloaded
    0
    How many kms?

    Haven't had any trouble with my Ranger

    Clean it off with a pressure washer and degreaser, run it and watch for the leak. If it's that bad you should be able to see where it's coming from
    Jock

    '87 110 Isuzu/Defender Hybrid

  4. #4
    Join Date
    Aug 2012
    Location
    Adelaide
    Posts
    2,757
    Total Downloaded
    0
    Jock! Thanks,

    It's done 90 000km. Used to be a Council truck though so it's 'true age' might be more like 120 000 or 150 000km... who knows. It's never given trouble before, other than just the stupid injector seals dieing... but that is apparently normal and isn't hard to fix if you know what your doing....

    I didn't get a chance to degrease it before I took it to work (had to finish the service late at night after work...) so I will degrease it tomorrow and try your suggestion of running it and seeing what happens!

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!