Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: I found an Unused Relay?

  1. #11
    Join Date
    Jun 2006
    Location
    Hay Point
    Posts
    3,670
    Quote Originally Posted by BadCo. View Post
    I think that blade fuse holder is just cable tied there for convenience.
    Yep, all the Perenties are cable tied onto the Jideco relay.
    Cheers......Brian
    1985 110 V8 County
    1998 110 Perentie GS Cargo 6X6 ARN 202516 (Brutus)

  2. #12
    Join Date
    Feb 2013
    Location
    Redcliffe
    Posts
    70
    So what this means is I may not have a relay for the EDIC motor, it may be a direct connection to the start switch. ☹️☹️😩
    Ex Military S2A - sold before the internet was invented.
    D4 with all the fruit
    110 Perentie FFR 51-558
    Haulmark PT1-1.2 204923

  3. #13
    Join Date
    Jun 2014
    Location
    Waitakere, New Zealand
    Posts
    1,209
    Quote Originally Posted by pwillo View Post
    So what this means is I may not have a relay for the EDIC motor, it may be a direct connection to the start switch. ☹️☹️😩
    Oh well, I doubt the EDIC is a massive load and it is only intermittent (turning the ignition on or off).

    Your headlights and their lack of relays is what you should be really worried about
    1988 Land Rover 110 Perentie Personnel Carryall 48-369
    Remlr 429

  4. #14
    Join Date
    Feb 2013
    Location
    Redcliffe
    Posts
    70
    I will have a better look at the wiring and try and work out if the relay has been bypassed, canít imagine it being too expensive to replace the relay. Hope itís not hiding some other problem.

    The headlights and light bar are running off a Traxide kit I installed shortly after purchase, so no problems there..
    Ex Military S2A - sold before the internet was invented.
    D4 with all the fruit
    110 Perentie FFR 51-558
    Haulmark PT1-1.2 204923

  5. #15
    Join Date
    Jun 2014
    Location
    Waitakere, New Zealand
    Posts
    1,209
    Quote Originally Posted by pwillo View Post
    I will have a better look at the wiring and try and work out if the relay has been bypassed, canít imagine it being too expensive to replace the relay. Hope itís not hiding some other problem.
    Those two blue things sticking out of the block will probably have a cable between them.

    Quote Originally Posted by pwillo View Post
    The headlights and light bar are running off a Traxide kit I installed shortly after purchase, so no problems there..
    Good man!
    1988 Land Rover 110 Perentie Personnel Carryall 48-369
    Remlr 429

  6. #16
    Join Date
    Jun 2006
    Location
    Hay Point
    Posts
    3,670
    It is not doing anything, just remove it and problem solved.
    Cheers......Brian
    1985 110 V8 County
    1998 110 Perentie GS Cargo 6X6 ARN 202516 (Brutus)

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!