Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: Before I start on the injectors.....

  1. #1
    Join Date
    May 2015
    Location
    Williamstown, Victoria
    Posts
    2,024

    Before I start on the injectors.....

    The engine, TD5 lacks power, will rev to 3500 when stationary. No smoke at all even when full throttle.
    Injector balance all over the place from -8 to +21 This I think is the decider. No faults in the ECU

    It could be....
    Boost hoses, these are silicon, do they de laminate?
    Injector loom/red ECU plug. New loom in Jan 2020 no oil on plug, and old loom was sealed at plug end.
    MAF no difference when disconnected.
    MAP?
    Fuel pump? How to check, I don't here it but then you need good ears for that. A full tank and drawers may muffle the sound.
    Waste gate? How to check? the rod has been shortened. This was done a few months ago. Max boost 22psi.
    FPR, how to check? It is not leaking.

    Any thing else to consider?
    D2a Td5 Manual, Chawton White. aka "Daisy"
    Build date 11th Oct 2002
    Freelander 2 2011, manual, the daughter calls it Perri
    Before I had a Land Rover I did not have any torque wrenches. Now I have three.

  2. #2
    Join Date
    Apr 2016
    Location
    Melbourne
    Posts
    2,993
    From memory:

    check fuel pump using oscilloscope to watch it's power requirements. Hard to do if you don't understand it.
    Just using a multimeter could work, but hard to watch it change it's current requirements.
    LR Toolbox shows you how too do this type of test.

    First half of the vid shows you to do earth tests, then how to understand an oscilloscope output on how worn the pump may be.

    FPR, you need a pressure gauge. Vid above shows the complications involved(for the average person).
    Cheers,
    Arthur.

    '99 D1 300 Tdi Auto

  3. #3
    Join Date
    Aug 2020
    Location
    Cooma
    Posts
    27
    Hello, just had a similar issue with mine and found that unplugging the MAF didn't make a difference until the car was restarted.

  4. #4
    Join Date
    May 2015
    Location
    Williamstown, Victoria
    Posts
    2,024
    Engine off MAF disconnected.
    I do not think it is the fuel pump.
    the bloody thing starts.
    I hope MLR Port Melbourne have the parts. I do not trust Aust Post to get the parts here on time from my regular supplier
    D2a Td5 Manual, Chawton White. aka "Daisy"
    Build date 11th Oct 2002
    Freelander 2 2011, manual, the daughter calls it Perri
    Before I had a Land Rover I did not have any torque wrenches. Now I have three.

  5. #5
    Join Date
    May 2015
    Location
    Williamstown, Victoria
    Posts
    2,024

    OIL in the red plug!! Injector removal tool

    Injector removal tool.jpg

    20201018_150735.jpg20201018_150745.jpg20201018_150832.jpg20201018_150928.jpg

    \How do I clean this? degreaser? or what. The ECU has security torch nuts!!
    Last edited by Bohica; 18th October 2020 at 02:19 PM. Reason: Oil in the red plug
    D2a Td5 Manual, Chawton White. aka "Daisy"
    Build date 11th Oct 2002
    Freelander 2 2011, manual, the daughter calls it Perri
    Before I had a Land Rover I did not have any torque wrenches. Now I have three.

  6. #6
    Join Date
    Apr 2016
    Location
    Melbourne
    Posts
    2,993
    Cheers,
    Arthur.

    '99 D1 300 Tdi Auto

  7. #7
    Join Date
    May 2015
    Location
    Williamstown, Victoria
    Posts
    2,024
    Bugger, no change. Back to the injector washers!!
    D2a Td5 Manual, Chawton White. aka "Daisy"
    Build date 11th Oct 2002
    Freelander 2 2011, manual, the daughter calls it Perri
    Before I had a Land Rover I did not have any torque wrenches. Now I have three.

  8. #8
    Join Date
    Jan 1970
    Location
    NSW far north coast
    Posts
    16,372
    Quote Originally Posted by Bohica View Post
    Injector removal tool.jpg

    20201018_150735.jpg20201018_150745.jpg20201018_150832.jpg20201018_150928.jpg

    \How do I clean this? degreaser? or what. The ECU has security torch nuts!!
    That amount of oil will affect things.
    I've even opened the ECU when it was bad and flushed it with contact cleaner too.

    Don't use degreaser, it will leave a film on the pins.

    And don't forget where the engine harness/loom plugs coming out of the head plugs into the main ECU loom.
    The oil will continue to track down there for ages, it will need reflushing regularly.

  9. #9
    Join Date
    May 2015
    Location
    Williamstown, Victoria
    Posts
    2,024
    I rinsed the degreaser off with methylated spirits.
    I'll have a look inside the ECU then.
    D2a Td5 Manual, Chawton White. aka "Daisy"
    Build date 11th Oct 2002
    Freelander 2 2011, manual, the daughter calls it Perri
    Before I had a Land Rover I did not have any torque wrenches. Now I have three.

  10. #10
    Join Date
    Jul 2014
    Location
    west of Transylvania
    Posts
    3,051
    Here's an easy check to see if the pump is working only on LP : Disco 2 - Check Td5 fuel pump HP | LandyZone - Land Rover Forum on LP the engine starts and runs but without power
    Discovery Td5 (2000), manual, tuned

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!