Results 1 to 4 of 4

Thread: Car won't start, Any suggestions?

  1. #1
    Join Date
    Feb 2017
    Location
    Middleton Grange
    Posts
    1

    Car won't start, Any suggestions?

    G'day, My FL2 2008 2.2 Diesel stopped yesterday and won't start. Until now it has been flawless, I am really happy with it (it's done 196,000 klm). I noticed the day before it was taking longer than usual for the engine to start, in the morning it took it two cranks to get it going. Then, as I was driving it started to loose power and eventually it came to a complete stop and it won't start any more. The engine turns ok when I try to start it.
    I unplugged the fuel line to the filter and it does not push any fuel out of it when I'm cranking it.
    Any ideas what the problem could be? Has any one else had a similar experience?
    Could it be the fuel pump?

    Thanks everyone

  2. #2
    Join Date
    Jun 2018
    Location
    Melbourne
    Posts
    833
    Quote Originally Posted by SamLR208 View Post
    G'day, My FL2 2008 2.2 Diesel stopped yesterday and won't start. Until now it has been flawless, I am really happy with it (it's done 196,000 klm). I noticed the day before it was taking longer than usual for the engine to start, in the morning it took it two cranks to get it going. Then, as I was driving it started to loose power and eventually it came to a complete stop and it won't start any more. The engine turns ok when I try to start it.
    I unplugged the fuel line to the filter and it does not push any fuel out of it when I'm cranking it.
    Any ideas what the problem could be? Has any one else had a similar experience?
    Could it be the fuel pump?

    Thanks everyone
    Don't know about the FL engines, but have you checked the fuel filter? You may have picked up a bad tank or even ran your tank too low and all the sludge has clogged the filter?
    Is the pump in the tank or on the motor? If it's on the motor that's why your not getting fuel with the line off lol....
    Are they "self bleeding" or do you have a primer pump on the filter?

    Cheers jim

  3. #3
    Join Date
    Oct 2009
    Location
    Hunter Valley
    Posts
    867
    They won't pump fuel out of the fuel filter. They only have a pump on the engine.
    You will need to see if there are any codes in they engine.
    You need a primer pump to bleed the fuel filter
    It doesn't leak oil, Its sweating power

  4. #4
    Join Date
    Apr 2015
    Location
    Hervey Bay
    Posts
    193
    G'day Sam,

    I've had a similar issue with ours with 200 thousand on the clock.

    My problem was with the crank angle sensor plug. If you reach right down on the drivers side of the engine to the crank angle sensor plug and give it a wiggle, then see if it starts. If it does start it's like mine and if you pull the wheel and inner guard you can get to the plug. Then get a scribe or a very small screwdriver and push the contacts of the plug back into the centre and see how that goes.

    But an OBDII scan will tell you more.
    04 L322 Vogue V8 - Work truck
    95 RRC Soft Dash - up for sale
    07 Freelander 2 TD4 SE - The wifes
    74 Jaguar XJ6
    74 Leyland P76 - now a rusted wreck
    91 Kawasaki GPZ900R
    96 Seadoo HX Jet Ski

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!