Results 1 to 3 of 3

Thread: Freelander 2 starting issues

  1. #1
    Join Date
    Dec 2019
    Location
    South Africa
    Posts
    1

    Freelander 2 starting issues

    Hi all, thanks for allowing me to join, appreciated.
    I have a 2013 Freelander 2 diesel auto, she recently developed an erratic starting issue. When I press the start button, the guages do their thing but she doesn't start. So, I keep my foot on the brake & shift the gearshift up & down & when it gets to Neutral, she starts. Just wondering if anyone else has had this & what is the remedy?
    Kind regards
    Pat

  2. #2
    Join Date
    Nov 2008
    Posts
    99
    Hi, noticed you never got any answers, thought you my be a bit lonley, hopefully got problem fixed. Not sure myself but most autos have a position sensor to start in park. Faulty on yours? Problem is FL 2's don't really have many problems barring rear diff and Land Rover's rather optimistic service schedule, so not many posts get put on. If you look back to threads can get an idea on proper service schedules. If you see this we are quite friendly.
    Joe

  3. #3
    Join Date
    Jan 1970
    Location
    Normanhurst - Sydney
    Posts
    7,364
    Could also be starter solenoid contacts have become worn/corroded. What mileage have you done?
    I had to mine on a 2009 model at about 180k.

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!