Results 1 to 8 of 8

Thread: Brake light on

  1. #1
    Join Date
    Jan 2020
    Location
    Shelbourne, Victoria
    Posts
    18

    Brake light on

    Hi All,

    I realised about a over a month ago that the right hand rear brake light faintly stays on when the car is running and stays on for around 14 minutes from shutting the doors after the engine has been turned off. I am guessing this is the time for the computers to shut down?

    53EA0B63-1AB5-4FD7-A81D-F741F7746EE6.jpg
    When we had the timing belts done the independent mechanic checked the diagnostics but no faults were logged, they suggested it could be a faulty rear light unit and replace the whole thing.

    So finally getting a weekend to look at the cause are there any suggestions on the best place to start looking for the culprit. There is also a second flat pin trailer plug installed under the rear bumper by the previous owner.

    cheers
    Jonathan
    Attached Images Attached Images

  2. #2
    Join Date
    Mar 2016
    Location
    Perth
    Posts
    2,320
    Mine had a light cluster replaced once but I donít know why that was done.
    2010 TDV6 3.0L Discovery 4 HSE
    2007 Audi RS4 (B7)

  3. #3
    Join Date
    Nov 2015
    Location
    Melbourne
    Posts
    514
    How odd. My guess is that you're right in suspecting the aftermarket wiring connected into the circuit. I'd certainly start by disconnecting it to see if it still happens.
    2013 D4 expedition equipped
    1966 Army engineering trailer
    (previously SII 2.25 swb, SIII 2.25 swb & lwb, P38 Vogue, 1993 LSE 3.9V8 then HS2.8)

  4. #4
    Join Date
    Jun 2013
    Location
    NSW Australia
    Posts
    486
    Do you have or did it ever have electronic brakes fitted, light assemblies can't generate there own electricity. Someone is sending a very very small amount of power to them
    If at first you do not succeed, maybe your just no good and should quit!

  5. #5
    Join Date
    Jan 2020
    Location
    Shelbourne, Victoria
    Posts
    18
    There is no brake controller fitted and the glow cannot really be seen in daylight.

  6. #6
    Join Date
    Jan 2007
    Posts
    1,119
    Short circuit prob in the added wiring...disconnect as suggested..

  7. #7
    Join Date
    Jun 2013
    Location
    NSW Australia
    Posts
    486
    In regards to led. Simple water in the connector is enough to cause that concern
    If at first you do not succeed, maybe your just no good and should quit!

  8. #8
    Join Date
    Apr 2012
    Location
    Whyalla, South Australia
    Posts
    2,831
    Something tracking over in second trailer plug.
    Cheers
    Tombie

    D4 MY11 - Stormy

    D90 MY15 - Ike
    D2 TD5

    Tesla Cybertruck Tri-Motor AWD On order...due 2021
    Gone - D1 AZZKIKR - 5.0L Supercharged with the lot
    Gone - Tombraider Defender - Lara
    Two wheels
    2007 Suzuki M109R LE
    2020 Suzuki Katana

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!