Results 1 to 7 of 7

Thread: 2003 3.0 Diesel, engine swapped new one not running right- injectors?

  1. #1
    Join Date
    Mar 2014
    Location
    Blackburn, VIC
    Posts
    143
    Total Downloaded
    0

    2003 3.0 Diesel, engine swapped new one not running right- injectors?

    So my motor got destroyed on the Simpson (a story for another day, not my fault nor the car) and replaced with one with only 130,000kms on it- just run in, right?* Anyway this one is way down on power, I have to downshift on the freeway to get up hills I used to go up with ease in 5th. Also fuel usage has gone up to 15.5 l/100km, from 13 (I have a roof rack with spare tyre, uses a bit). A friend has suggested it might be because the injectors haven't been coded to the existing engine computer since that can be an issue with TD5s. Is this a thing with the BMW M57?
    Failing that, any ideas? I had a similar power issue a few years ago with the old motor, turned out to be a failed turbo hose and an easy fix. New hoses fitted along with a new turbo this time so I doubt it's that. Not hearing any untoward whistling etc.
    TIA for your thoughts.

    *mine had almost 400k on it, gutted it didn't make it. Was planning on it being a 1,000,000km engine.

    Edit: forgot to mention that when the engine was changed over I also had an EGR blanking plate fitted. I have an IIDtool, it's reporting the following fault:

    P0401-20
    extended fault path exhaust gas recirculation governor deviation- negative deviation
    Last edited by Strangerover; 28th May 2022 at 12:48 PM. Reason: typo, add info

  2. #2
    Join Date
    Dec 2017
    Location
    wandin nth vic
    Posts
    490
    Total Downloaded
    0
    M57 injectors dont need to be coded.
    Sounds boost related. Need a scan tool to save guessing.

  3. #3
    Join Date
    Mar 2014
    Location
    Blackburn, VIC
    Posts
    143
    Total Downloaded
    0
    Quote Originally Posted by theelms66 View Post
    M57 injectors dont need to be coded.
    Sounds boost related. Need a scan tool to save guessing.
    Thanks for responding. I've been finding it hard to get a straight answer from Google searches on whether coding is required. Seems odd that these don't need it when most others do, but if these don't that's a plus.

    When the engine was changed over I also had an EGR blanking plate fitted. I have an IIDtool, it's reporting the following fault:

    P0401-20
    extended fault path exhaust gas recirculation governor deviation- negative deviation

    ...so I'm guessing this has something to do with it.
    The engine just feels breathless at higher RPMs.

  4. #4
    Join Date
    Dec 2017
    Location
    wandin nth vic
    Posts
    490
    Total Downloaded
    0
    I've fitted 2 new injectors with no coding or issues.
    Your fault code relates to the egr blanking plate , you can disregard the fault.
    Maybe log into the gap tools live values and have a look at your sensor readings . Manifold pressure, maf and so on.

  5. #5
    Join Date
    Mar 2007
    Location
    Canberra
    Posts
    746
    Total Downloaded
    0
    Check that your low pressure fuel pumps are delivering fuel adequately, also could be fuel filter ?

    Laurie
    2010 TdV8 Autobiography, D2 Td5, RRC 4 Door VM/300Tdi, RRC 2 Door V8

  6. #6
    Join Date
    Mar 2014
    Location
    Blackburn, VIC
    Posts
    143
    Total Downloaded
    0
    Quote Originally Posted by theelms66 View Post
    I've fitted 2 new injectors with no coding or issues.
    Your fault code relates to the egr blanking plate , you can disregard the fault.
    Maybe log into the gap tools live values and have a look at your sensor readings . Manifold pressure, maf and so on.
    Thanks, I'll do that- but have no idea what the values should be. If I posted them here would you know what story they were telling?

  7. #7
    Join Date
    Dec 2017
    Location
    wandin nth vic
    Posts
    490
    Total Downloaded
    0
    Quote Originally Posted by Strangerover View Post
    Thanks, I'll do that- but have no idea what the values should be. If I posted them here would you know what story they were telling?
    Hopefully someone will make sense of them. I can collect readings off mine and compare.

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!