Results 1 to 6 of 6

Thread: Reset service indicator

  1. #1
    Join Date
    Jan 2012
    Location
    Geelong Vic
    Posts
    154

    Reset service indicator

    Hi, Is there any way to do this on my 2015.5 tdv6 Vogue, (without using any black box etc).I imagine anything that works on similar age RR Sport would be ok.
    Thanks, Peter
    2015.5 RR Vogue TDV6
    2016 XE Jag 20D Prestige
    2003 MB SL500

  2. #2
    Join Date
    May 2003
    Location
    On The Road
    Posts
    29,217
    I wouldnt think so,, obviously LR do it when serviced. I would have thought any business confident enough to take on a 2015FFRR service would have that covered...
    "How long since you've visited The Good Oil?"

    '93 V8 Rossi
    '97 to '07. sold.
    '01 V8 D2
    '06 to 10. written off.
    '03 4.6 V8 HSE D2a with Tornado ECM
    '10 to '21
    '16.5 RRS SDV8
    '21 to Infinity and Beyond!


    2017 Crusader Excalibur Prince
    A whole lotta Rosie-


  3. #3
    Join Date
    Oct 2012
    Location
    Gold Coast
    Posts
    126
    Quote Originally Posted by peter g View Post
    Hi, Is there any way to do this on my 2015.5 tdv6 Vogue, (without using any black box etc).I imagine anything that works on similar age RR Sport would be ok.
    Thanks, Peter
    Here is the answer

    L405 Range Rover Service Reset - YouTube

  4. #4
    Join Date
    Jan 2012
    Location
    Geelong Vic
    Posts
    154
    Quote Originally Posted by orangepop View Post
    Hi, Many thanks for the response, I have followed the process precisely several times however cant get the "resetting service indicator" message to come up. Has anyone actually used this process, or any suggestions ?
    Thanks, Peter
    2015.5 RR Vogue TDV6
    2016 XE Jag 20D Prestige
    2003 MB SL500

  5. #5
    Join Date
    Oct 2012
    Location
    Gold Coast
    Posts
    126
    Quote Originally Posted by peter g View Post
    Hi, Many thanks for the response, I have followed the process precisely several times however cant get the "resetting service indicator" message to come up. Has anyone actually used this process, or any suggestions ?
    Thanks, Peter
    ☹️

  6. #6
    Join Date
    Jan 2012
    Location
    Geelong Vic
    Posts
    154
    It seems that although I didnt get the reset message, that the procedure worked. Since then I have not had a service needed notice come up as was the case previously.
    2015.5 RR Vogue TDV6
    2016 XE Jag 20D Prestige
    2003 MB SL500

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!