Results 1 to 4 of 4

Thread: p38 hevac

  1. #1
    Join Date
    Jul 2011
    Location
    burpengary
    Posts
    109

    p38 hevac

    hi all, my hevac panel works as far as i can tell...car not going ,engine still to install since purchase, i replaced all the bulbs to get working but the green screen does not show all the numbers,symbols etc. if you touch it it changes a little but is not easy to read. is there a trick to fixing this? any advice appreciated.

  2. #2
    Join Date
    Jan 2016
    Location
    Netherlands
    Posts
    243
    matrix display problems usually relate to the ribbon cable behind the display. It can be fixed, check this: YouTube

    There are more examples floating around if you take a minute to google. Seems like a doable DIY job.

    Cheers,
    -P

  3. #3
    p38arover's Avatar
    p38arover is offline Major Part of the Heart and Soul of AULRO Gold Subscriber
    Join Date
    Jan 1970
    Location
    Western Sydney
    Posts
    26,647
    Here's something John Brabyn and I wrote up some years back - it might help: LCD Backlight Repair
    Ron B.
    VK2OTC

    2004 L322 Range Rover Vogue 4.4 V8 Auto
    2007 Yamaha XJR1300
    Previous: 1983, 1986 RRC; 1995, 1996 P38A; 1995 Disco1; 1984 V8 County 110; Series IIA



    RIP Bucko - Riding on Forever

  4. #4
    Join Date
    Jul 2011
    Location
    burpengary
    Posts
    109
    thanks guys, will check these links out.

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!