Results 1 to 6 of 6

Thread: P38 Flashing interior lights

  1. #1
    Join Date
    Jul 2018
    Location
    Tasmania
    Posts
    2

    P38 Flashing interior lights

    Hi Guys,
    I have a electrical fault with my 1995 P38, every time I turn the ignition on the climate control LCD screen flashes and so does the lights (traction control lights ect.) on the instrument cluster as well as the foot lamps. now I've done some trouble shooting trying to find the issues so I've checked the battery, alternator and wiring looms and I've came to the conclusion its a bad earth wire to all the plugs that connect to the LCD screen and instrument cluster because at the back of the plugs the earth wire shows voltage so could any one help me try to identify where the earth is located for this plugs behind the centre console.
    cheers Joe

  2. #2
    Join Date
    Jan 2016
    Location
    Netherlands
    Posts
    258
    If memory serves: a lot comes from the BeCM but I'll have a look in my wrecker tonight for you Since the dash is out it should be fairly easy to see.

    Cheers,
    -P

  3. #3
    TheTree is offline ChatterBox Silver Subscriber
    Join Date
    Feb 2013
    Location
    Gosford, NSW, Australia
    Posts
    2,510
    Have you checked the earths behind the kick panel on the side in front of the door (the one with the bonnet release lever)? Also the BECM earths (have to remove seat to get at this one)

    Steve
    MY96 4.6 HSE P38. Niagara Grey; "The Phoenix"
    MY99 4.6 HSE P38. LPG, Blenheim Sliver; "Voldemort" burnt to a cinder
    MY79 RR Classic, Gone, MY57 Series 1 SWB, Long gone
    P38 write ups and info on my website http://p38.hts.com.au/

  4. #4
    Join Date
    Jul 2018
    Location
    Tasmania
    Posts
    2
    I've checked the earth point down on the kick panel at drives feet and that seems but the earth cables going to that point are showing voltage and when I connect an alternate earth wire to them nothing changes so does that mean them earth cables going to the point are broken along the way or just playing tricks?

  5. #5
    TheTree is offline ChatterBox Silver Subscriber
    Join Date
    Feb 2013
    Location
    Gosford, NSW, Australia
    Posts
    2,510
    Quote Originally Posted by Joe88 View Post
    I've checked the earth point down on the kick panel at drives feet and that seems but the earth cables going to that point are showing voltage and when I connect an alternate earth wire to them nothing changes so does that mean them earth cables going to the point are broken along the way or just playing tricks?
    Hi

    They tend to corrode, I use DeOxit on them but any good contact cleaner should work, just check all is clean and tight

    Steve
    MY96 4.6 HSE P38. Niagara Grey; "The Phoenix"
    MY99 4.6 HSE P38. LPG, Blenheim Sliver; "Voldemort" burnt to a cinder
    MY79 RR Classic, Gone, MY57 Series 1 SWB, Long gone
    P38 write ups and info on my website http://p38.hts.com.au/

  6. #6
    Join Date
    Jan 2016
    Location
    Netherlands
    Posts
    258
    I just checked my wrecker and I can't find that many earth points. Indeed at the bonnet lever are some and I found a single earthing point connected at the splicing point where the plugs for the radio and switches, including hevac are located. Since I long since disassembled that part of the car I am not sure anymore where that once was connected to but I should think to the steel frame of the dashboard, which in turn means that the connecting points of that frame would also need to be checked. There is a possibility that the ground ring was connected somewhere down low, around the gear lever.

    Just what I could find, I think most other grounding is indeed done directly from the BeCM.

    -P

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!