Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: my 110 county turbo build thread

  1. #21
    Join Date
    Sep 2017
    Location
    Melbourne
    Posts
    15
    Quote Originally Posted by asmit View Post

    I could not source a V-band clamp to suite the cummins flange, so I welded to it, tig on the inside to seal it, then mig the outside for streangth and looks. I did make a point of fitting a 2.5" vband clamp just under the turbo there to make the exhaust easily removable.

    Attachment 142137
    asmit, is that the 2.5" dump pipe?

  2. #22
    Join Date
    Jan 2007
    Posts
    940
    Just buy or make a steel undivided 10-12mm T4 spacer...we did..cost 60 bucks tho at a speed shop..drill out the threaded holes which are normally used for inlet manifolds...get another gasket and away u go.

    Simple...also gives more space to reuse the heater pipes..with a little re bending to clear the compressor housing.

  3. #23
    Join Date
    Aug 2015
    Location
    Brisbane
    Posts
    64
    Quote Originally Posted by McBrain283 View Post
    asmit, is that the 2.5" dump pipe?
    Yes that is 2.5" pipe. Just downstream of the vband clamp there it expands into a 3" pipe.

    Quote Originally Posted by INter674
    Just buy or make a steel undivided 10-12mm T4 spacer...we did..cost 60 bucks tho at a speed shop..drill out the threaded holes which are normally used for inlet manifolds...get another gasket and away u go.
    Do you mean T3? (the HX30w is T3 and this model of manifold is T3)

    This is a good approach, definitely makes the job less work to re-use the heater pipes, and a convenient location for the EGT probe!

  4. #24
    Join Date
    Jan 2007
    Posts
    940
    Yes sorry T3..got club hands😐

  5. #25
    Join Date
    Jan 2007
    Posts
    940
    Re the dump pipe..we intended 3" all the way but the pipe is too big to avoid damage on a Perentie being located under the door sill so were going 3 into 2.5".

  6. #26
    Join Date
    Sep 2017
    Location
    Melbourne
    Posts
    15
    Finally got it all together and running. Took if for a long test run on the weekend and all good so far.

    1.5 turns out on the fuel and making 630egt pre-turbo. I don't have a boost gauge on it yet but the clutch slips at those egts in 4th gear on the big hill.

    Got a bunch of bits to clean up but she's 99% there.

    Exhaust is temporary as I will go bigger from the dump pipe aft when I get a chance to mod it.
    Attached Images Attached Images

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!