Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 39

Thread: Cameo reversion

  1. #21
    Join Date
    May 2006
    Location
    South West Rocks
    Posts
    6,307
    I think i went from 1.4 which came on the gun to a 2.0 and the paint then went on beautifully. 1.4 was splattery and dry.
    Damien
    ------------------------------------------------

  2. #22
    Join Date
    May 2006
    Location
    South West Rocks
    Posts
    6,307
    Also do you have a build thread on this car?
    Damien
    ------------------------------------------------

  3. #23
    Join Date
    Jan 1970
    Location
    Brisbane, Queensland
    Posts
    4,120
    I had a 2.0. I should have given it a try.

    I've had this Perentie since 2001. First got it on the road in 2006. I think I put up some pics back then.
    L322 tdv8 poverty pack - wow
    Perentie 110 wagon ARN 49-107 (probably selling) turbo, p/steer, RFSV front axle/trutrack, HF, gullwing windows, double jerrys etc.
    Perentie 110 wagon ARN 48-699 another project
    Track Trailer ARN 200-117
    REMLR # 137

  4. #24
    Join Date
    Jan 2016
    Location
    Lane Cove
    Posts
    43

    colour

    Did concept have the colours you wanted on their colour cards or was it a match job?The truck looks very neat

  5. #25
    Join Date
    Jan 1970
    Location
    Brisbane, Queensland
    Posts
    4,120
    Here's a few pics from my first refurb taken in about 2004.


    And on a trip.

    L322 tdv8 poverty pack - wow
    Perentie 110 wagon ARN 49-107 (probably selling) turbo, p/steer, RFSV front axle/trutrack, HF, gullwing windows, double jerrys etc.
    Perentie 110 wagon ARN 48-699 another project
    Track Trailer ARN 200-117
    REMLR # 137

  6. #26
    Join Date
    Jan 1970
    Location
    Brisbane, Queensland
    Posts
    4,120
    Quote Originally Posted by thomson View Post
    Did concept have the colours you wanted on their colour cards or was it a match job?The truck looks very neat
    Thanks.

    It was a colour match.
    L322 tdv8 poverty pack - wow
    Perentie 110 wagon ARN 49-107 (probably selling) turbo, p/steer, RFSV front axle/trutrack, HF, gullwing windows, double jerrys etc.
    Perentie 110 wagon ARN 48-699 another project
    Track Trailer ARN 200-117
    REMLR # 137

  7. #27
    Join Date
    Jan 1970
    Location
    Brisbane, Queensland
    Posts
    4,120
    A progress photo. Nearly there. Thank you again Roverlord Offroad Spares for some last minute parts.



    I started it today for the 1st time in nearly 3 years. With junk and water in the fuel it didn't run for long. Cleaned the water trap, drained the tank, and changed the inline pre filter and factory spin on filter. I think I have an air leak as it doesn't want to start.

    The stop control was also seized up and got very hot when it couldn't move. Gave it a couple of taps with a soft hammer, which freed it up.
    L322 tdv8 poverty pack - wow
    Perentie 110 wagon ARN 49-107 (probably selling) turbo, p/steer, RFSV front axle/trutrack, HF, gullwing windows, double jerrys etc.
    Perentie 110 wagon ARN 48-699 another project
    Track Trailer ARN 200-117
    REMLR # 137

  8. #28
    Join Date
    Jun 2006
    Location
    Hay Point
    Posts
    3,592
    She looks good Pete!
    Cheers......Brian
    1985 110 V8 County
    1998 110 Perentie GS Cargo 6X6 ARN 202516 (Brutus)

  9. #29
    Join Date
    Jan 1970
    Location
    Brisbane, Queensland
    Posts
    4,120

    Cameo reversion

    The motor is running very nicely now, and did a oil and filter change. Also there was the usual sludge in the water trap.

    The stop control is still playing up. I will have to track one down before it dies. Anyone sourced one lately?
    L322 tdv8 poverty pack - wow
    Perentie 110 wagon ARN 49-107 (probably selling) turbo, p/steer, RFSV front axle/trutrack, HF, gullwing windows, double jerrys etc.
    Perentie 110 wagon ARN 48-699 another project
    Track Trailer ARN 200-117
    REMLR # 137

  10. #30
    Join Date
    Nov 2009
    Location
    Western Victoria
    Posts
    12,552
    Quote Originally Posted by rar110 View Post
    The motor is running very nicely now, and did a oil and filter change. Also there was the usual sludge in the water trap.

    The stop control is still playing up. I will have to track one down before it dies. Anyone sourced one lately?
    I remember reading a thread a few months back. Not sure if it was on here or REMLR.
    Unless otherwise stated, this post is the opinion of Mick_Marsh and should be read accordingly.

    Hybrid SIII Stage 1 cab on a RRC chassis

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!