Results 1 to 6 of 6

Thread: Air con through vents

  1. #1
    Join Date
    Sep 2019
    Location
    Bluewater
    Posts
    1

    Air con through vents

    Hi guys
    I have a 2002 discovery 2 td5, which slightly got wet during the floods. I replaced the fan, as it was not working.
    With new fan I am not getting enough air flow out of the vents. The fan is cranking a lot of air.
    What could be the issue?
    Are there blocked filters or some shut off gates not ooening?
    Done a self test on dislay and all good.

  2. #2
    Join Date
    Nov 2007
    Location
    Townsville Nth Qld
    Posts
    527
    Mate Your location shows as Bluewater, is that north of Townsville? If yes i can come and and have a look your call at no cost of course. I found td5 aircons finicky things like you need to be at operating temp for things to work right.



    I have a 2002 discovery 2 td5, which slightly got wet during the floods. I replaced the fan, as it was not working.
    With new fan I am not getting enough air flow out of the vents. The fan is cranking a lot of air.
    What could be the issue?
    Are there blocked filters or some shut off gates not ooening?
    Done a self test on dislay and all good.[/QUOTE]

  3. #3
    Join Date
    Jan 2013
    Location
    WA
    Posts
    179
    could be the blend flap motors have seized if the water got into them, just unclip the flap and work the motor it might just free it up.
    D2 2004 TD5 Classic

    --------------------------------------

  4. #4
    Join Date
    Jan 1970
    Location
    Adelaide Hills. South Australia
    Posts
    3,581
    Of course you would have re-fitted the Blower Wheel the right way around & wired it so it runs in the correct direction?



    Of course you would have.


    Just sayin'.

  5. #5
    Join Date
    Dec 2007
    Location
    Brisbane West
    Posts
    19,664
    Quote Originally Posted by 4bee View Post
    Of course you would have re-fitted the Blower Wheel the right way around & wired it so it runs in the correct direction?



    Of course you would have.


    Just sayin'.
    My initial thought, too.
    If you don't like trucks, stop buying stuff.
    http://www.aulro.com/afvb/signaturepics/sigpic20865_1.gif

  6. #6
    Join Date
    Jan 1970
    Location
    Adelaide Hills. South Australia
    Posts
    3,581
    Bloody hell 58i, don't tell me we actually agree on something?

    Has happened, but not to me it hasn't, but I would say that wouldn't I.

    Simple mistakes to make especially if one is under pressure (or the pump.)

    The other cause could possibly be the wheel &/or ducts are chokkas with ****.

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!