Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: SUSPENSION SQUEAKS

  1. #1
    Join Date
    Oct 2009
    Location
    St George Dragons Territory, NSW
    Posts
    746

    SUSPENSION SQUEAKS

    Over the weekend as I was doing some running around with the window down and I noticed a real squeak from my suspension as I went over speed bumps, into and out of driveways etc.

    It was fairly intermittent, however as I has done less than 40K and I am aware of suspension bushes, ball joints etc been a potential problem I though I would seek some feedback from those with much greater technical knowledge than I posses.

    It is a 2009 TDV6 SE, any thoughts, should I get it seen to straight away or wait until next service in a couple of months.

    It is not annoying enough to be a bother an only noticeable at slow speed with with the windows down. I have not noticed any play in steering or change in handling so for what it is worth.

    Regards,

    George

  2. #2
    Join Date
    Feb 2010
    Location
    Mount Martha
    Posts
    1,307
    Quote Originally Posted by DiscoWeb View Post
    Over the weekend as I was doing some running around with the window down and I noticed a real squeak from my suspension as I went over speed bumps, into and out of driveways etc.

    It was fairly intermittent, however as I has done less than 40K and I am aware of suspension bushes, ball joints etc been a potential problem I though I would seek some feedback from those with much greater technical knowledge than I posses.

    It is a 2009 TDV6 SE, any thoughts, should I get it seen to straight away or wait until next service in a couple of months.

    It is not annoying enough to be a bother an only noticeable at slow speed with with the windows down. I have not noticed any play in steering or change in handling so for what it is worth.

    Regards,

    George
    Hi George,
    This was response in another thread........Hi Kev,
    Believe it or not, mine had the squeaky suspension as well. Had to have the front drivers side shocker replaced, then the front stabilizer bar bushes. Apparently the bushes in these aren't too good, so they replace them with better ones.
    No more squeaks now but still have the shuddering mirror.
    Cheers, Craig

  3. #3
    Join Date
    Jan 1970
    Location
    Douglas Park, NSW
    Posts
    9,198
    Squeaks are usually down to dry sway bar bushes.
    Movement in the bushes usually results in a knock but if you just have a squeak, then chances are they're just dry (or full of Lithgow mud ).
    Scott

  4. #4
    Join Date
    May 2009
    Location
    perth w.a.
    Posts
    1,221
    i maybe just dust in the bushes give it a good hit with a high pressure water hose and see if that helps

  5. #5
    Join Date
    Mar 2008
    Location
    Sydney, Australia
    Posts
    2,353
    Silicone spray?

  6. #6
    Join Date
    Feb 2010
    Location
    Mount Martha
    Posts
    1,307
    Hi again George,
    I almost guarantee that it will be the front stabilizer bushes. I was told that this was a common fault because the originals are poor quality. The new ones are supposed to be a big improvement and shouldn't wear any where near as quick.
    My D4 is also a 2009 TDV6 SE.
    Let me know how you go.
    Regards, Craig

  7. #7
    Join Date
    Oct 2009
    Location
    St George Dragons Territory, NSW
    Posts
    746
    Thanks for the replies,

    I did not think it was anything to drastic and as Scouse mentioned might have a bit of mud and dirt in there, that Newnes mud hole strikes again.

    I will get it looked into at the next service and have a crack a lubricating and cleaning in the mean time.

    Regards,

    George

  8. #8
    Join Date
    May 2010
    Location
    Brisbane, QLD, Australia
    Posts
    1,932
    Quote Originally Posted by DiscoWeb View Post
    Thanks for the replies,

    I did not think it was anything to drastic and as Scouse mentioned might have a bit of mud and dirt in there, that Newnes mud hole strikes again.

    I will get it looked into at the next service and have a crack a lubricating and cleaning in the mean time.

    Regards,

    George
    Hey George,

    I've got a 2009 SE TDV6 also.

    Yup, I've asked about this in an earlier thread and got feedback from dead shocks to just the need for lube.

    I've just built a new house and work has been flat out, so as the car was driving fine, I haven't got off my arse to do anything about it as yet.

    Sounds like LR will have something to do when mine goes in at the end of the month.

    Cheers.

    Kev.

  9. #9
    Join Date
    Sep 2008
    Location
    Perth
    Posts
    511
    My suspensions make the squeak noise too. Took it into LR and they said it was just heaps of mud and dirt.

    They washed it out and its better, but still the noise is slightly there when you are offroad. LR said there is no problem just part of a 4WD.

    Dorko

  10. #10
    Join Date
    Apr 2008
    Location
    Kenya
    Posts
    228
    Had squeaky bushes once - was waiting for dealer to get spares, then one day the squeaking stopped on its own! Sometimes I think the car's alive, lol. Got to love Land Rovers!

Page 1 of 2 12 LastLast

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!