Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Disco 3 transmission issues

  1. #1
    Join Date
    Jan 2015
    Location
    Grafton nsw
    Posts
    14

    Disco 3 transmission issues

    Looking for some advice ref tranny oddities, I have a My 05 petrol disco 3 and lately it has developed a few gremlins
    1 at round town speeds the tachometer has a noticeable "hunt" of around 300 rpm, if you listen carefully you can hear the engine speed change accordingly so it's not a tachometer playing up.
    2 about every 300 or so Kim's of highway driving the tranny drops into limited gear mode. This usually occurs on kick down when going up hill. Hasn't happened at around town speeds just highway driving. Doesnt happen in command shift just in auto.

    Any thoughts appreciated

  2. #2
    Join Date
    Aug 2010
    Location
    Sydney
    Posts
    1,827
    Hi Disco-------,
    A few other answers will help:
    How many kms has the car done?
    Has the auto been serviced?
    If so how often?

    The auto should really be serviced every 50,000 - 60,000 k to prolong it's life.
    If it had it's first change over 100,000 then some damage will have already been done to it, even if you then had it serviced every 50,000 there after.

    What should you do?
    Get the auto serviced and flushed is the first thing.
    If you have shudder get them to add Dr Tranny as per here:
    http://www.aulro.com/afvb/d3-d4-rrs/...udder-fix.html

    If all else fails then you will need to recondition the auto.

    Mine had the variation in revs too, some shudder and also a PO741 fault code recorded - Torque Converter Clutch solenoid stuck off or faulty.
    Nearing the point where I decided to have the rebuild done I had a weird occasion that the box threw up a transmission fault which meant the auto was fine at 100 / 110kph doing approx 2100 revs on the flat then uphill the revs would go up to 3200 revs without changing gear! Slippage
    Then downhill the gearbox would disengage resulting in revs being on idle speed!
    Weird.

    Get my D3 back this week after Toll lost my gearbox for 5 days

    Rich

  3. #3
    Join Date
    Feb 2004
    Location
    Williams West Aust
    Posts
    20,992
    Have you read this thread??? Lots of info on gearboxes there.
    http://www.aulro.com/afvb/d3-d4-rrs/...ssion-faq.html
    Goodluck
    Andrew
    DISCOVERY IS TO BE DISOWNED
    Midlife Crisis.Im going to get stuck into mine early and ENJOY it.
    Snow White MY14 TDV6 D4
    Alotta Fagina MY14 CAT 12M Motor Grader
    2003 Stacer 525 Sea Master Sport
    I made the 1 millionth AULRO post

  4. #4
    Join Date
    Jan 2015
    Location
    Grafton nsw
    Posts
    14
    Thx for the reply. Car has 190 k on it. Last service the trany gasket was leaking so the nice landrover man in Coffs Harbour changed it. As best as I can tell the issue started then. Do these tyranny shave filters in them? May get them to pull the pan off and change oil/ filter again, who knows. The box run fine otherwise no shudder or clunks but have noticed sometimes the change from first to second when moving off is not as smooth as I remember, car almost " stumbles" which is as best as I can describe it.

  5. #5
    Join Date
    Jan 2015
    Location
    Grafton nsw
    Posts
    14

    Curious

    Further to my last, there is some very good info on this fault on the pommie disco 3 site. The main offender appears to be the auto box gear shift lever pin seizing up. The info provided on that site is pretty conclusive and fits my symptoms to a t. Gunna order one today cheap part and reasonably easy to change, who knows but sounds good to me as I don't suspect the tranny at all as it runs very well. Cheers

  6. #6
    Join Date
    May 2007
    Location
    Junortoun Vic
    Posts
    76
    Did the nice serviceman use the absolutely correct transmission fluid?

  7. #7
    Join Date
    Jan 2015
    Location
    Grafton nsw
    Posts
    14
    Well they are the only landrover specialist on the north coast so one would hope so but I'm never convinced they always get it right. I'm going to get the box fluid redone at a transmission specialist shortly

  8. #8
    Join Date
    Apr 2011
    Location
    Coffs Harbour
    Posts
    456
    I use Stapletons in Coffs and used genuine fluid. He does a good job at a reasonable price
    2012 Fuji White 3.0 D4, Rear view camera, Hi-line sound, E-diff, Xenon lights, ARB winch bar, Lightforce 240 50w HID. Brads sliders.

  9. #9
    Join Date
    Jan 1970
    Location
    NSW South West Slopes
    Posts
    9,750
    Quote Originally Posted by Discoagogo View Post
    Well they are the only landrover specialist on the north coast so one would hope so but I'm never convinced they always get it right. I'm going to get the box fluid redone at a transmission specialist shortly
    Why not ask them what fluid was used?
    MY12 RRV 4.4 TDV8 AB, +LLAMS, +e-diff, +ACC stop/go. Produce LLAMS for LR/RR, Jeep GC/Dodge Ram
    VK2HFG and APRS W1 digi

  10. #10
    Join Date
    Jan 1970
    Location
    Bangor, NSW
    Posts
    1,499
    190,000km on original ATF... only another 50,000km to go until Land Rover reckon it needs to be changed! rofl

    Sorry about your symptoms - I really hope a shift lever pin is really the cause of your problem. I suspect the ATF is well and truly cooked.
    Bangor, NSW
    MY13 D4 3L TDV6 and MY11 D4 2.7L TDV6; ex-MY07 D3 SE TDV6; + too many other vehicles!

Page 1 of 2 12 LastLast

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!