Results 1 to 10 of 10

Thread: OT - EL Ford Auto

  1. #1

    OT - EL Ford Auto

    I have just changed the auto trans in an EL Ford.
    I got the "new" one from a wreckers
    I have installed it, but only have 1st and reverse. It has enough fluid (and the right type TQ95).
    I have connected all the wires etc to the box, but also have no speedo.
    Is the whole auto stuffed?

    Thanks
    Andrew

  2. #2
    Join Date
    Jul 2006
    Location
    Armidale NSW
    Posts
    82

    Falcon Power

    Maybe a quick check of the fuses may help,
    also the gear position switch on the side of the auto gives trouble in ef/el falcons, hope this helps

  3. #3
    Hey Andrew,
    Go intro yourself to the folks on Fordmods forum, they are more than helpful there as well. You may find a quicker answer there too for ford related probs.

    http://www.fordmods.com/forums/index.php

  4. #4
    Thanks guys, fuses all look OK, and the selector will move to all the gears.
    I will post it at the other forum, but from a quick check of there posts it looks like one or more of the solenoids are stuffed.

    Thanks
    Andrew

  5. #5
    Join Date
    Jan 1970
    Location
    In my D2a Ripping It Up
    Posts
    8,017
    Quote Originally Posted by RR5L
    Hey Andrew,
    Go intro yourself to the folks on Fordmods forum, they are more than helpful there as well. You may find a quicker answer there too for ford related probs.

    http://www.fordmods.com/forums/index.php
    well rob good to see you are getting into the flow of the better things in life
    cheers chris


    My Toy 04 D2a Td5 Manual With Lots of Goodie Goodness
    S111 Swb a work in progress
    Two Wheel Fun Factor
    Triumph Sprint St 955i

  6. #6
    Join Date
    Feb 2004
    Location
    Williams West Aust
    Posts
    21,057
    Sounds like a computor issue????
    Andrew
    DISCOVERY IS TO BE DISOWNED
    Midlife Crisis.Im going to get stuck into mine early and ENJOY it.
    Snow White MY14 TDV6 D4
    Alotta Fagina MY14 CAT 12M Motor Grader
    2003 Stacer 525 Sea Master Sport
    I made the 1 millionth AULRO post

  7. #7
    Join Date
    Jan 1970
    Location
    Kyabram, VIC 3620
    Posts
    2,543
    Quote Originally Posted by Andrewpv01
    I have just changed the auto trans in an EL Ford.
    I got the "new" one from a wreckers
    I have installed it, but only have 1st and reverse. It has enough fluid (and the right type TQ95).
    I have connected all the wires etc to the box, but also have no speedo.
    Is the whole auto stuffed?

    Thanks
    Andrew
    On the wifes ED falcon she had only 1st (not sure about reverse) and the speedo wasn't working - not sure if an EL has the same setup with an electronic speedo.

    The fault was that the speedo wire wasn't connected/had come off !!!!!

    Re-connected it and bob's your uncle - right as ninepence.

    Just a thought.

  8. #8
    Quote Originally Posted by rangieman
    well rob good to see you are getting into the flow of the better things in life
    Always willing to help out !

  9. #9
    Thanks Ladas,
    Talked to the blokes at an auto place today and they said the same thing. If it has no speedo it will not change up.
    I definately connected it, but the speedo drive could be shot. The speedo worked fine on the old one so I will swap them over and see if that helps.

    Andrew

  10. #10
    Join Date
    Jan 1970
    Location
    Kyabram, VIC 3620
    Posts
    2,543
    Quote Originally Posted by Andrewpv01
    Thanks Ladas,
    Talked to the blokes at an auto place today and they said the same thing. If it has no speedo it will not change up.
    I definately connected it, but the speedo drive could be shot. The speedo worked fine on the old one so I will swap them over and see if that helps.

    Andrew
    Might want to check the speedo sender unit in the 'new' box - especially if the old speedo worked.

    Could change it over from the old box and try it. Seems quite an easy/quick job.

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!