Results 1 to 3 of 3

Thread: Sudden Powerloss on Take-off

  1. #1
    Join Date
    Jun 2020
    Location
    Adelaide
    Posts
    2

    Unhappy Sudden Powerloss on Take-off

    I purchased my 2013 Landrover Freelander 2 SE SD4 automatic diesel (122000kms) from new and have had no issues for the first 4.5 years and love the car.
    Approx. 2 years ago in winter it started playing up with a sudden powerloss issue when taking off from idling at red lights (which can be dangerous).
    I press the accelerator lightly, the car would start to move and then suddenly become non-responsive (like it was not getting fuel), then after pressing harder and after approx. 3 seconds it would suddenly take off.

    The dealer investigated the issue and found that the intake manifold was carbonised due to too much city driving.
    After the car was decarbonised the problem went away for 2 years and now has returned and is getting worse.

    I did get some fault codes to do with 'Water in the fuel' and a faulty 'Water in fuel sensor'.
    I landrover wiring harness modification was made to allow clearing these error codes after replacing the sensor.

    The problem keeps re-occurring now almost every day I drive the car now.
    It rarely occurs when the engine is cold even though once or twice it idled rough - almost stalling when I put it in 'D' and tried to take off on a cold morning.
    The issue usually happens after about 5-10 km's or even after a long drive, switching off, and back on after half an hour.
    I am getting no fault codes using my iCarsoft scanner.

    So I spent heaps$ to have the inlet manifold & intercooler cleaned and have had a oil catch can fitted.

    The problem still occurs! What do I do next?
    High pressure fuel pump? EGR valve? Throttle body? accelerator sensor?
    Has anyone had this issue and can point me in the right direction.
    Cheers Jom

  2. #2
    Join Date
    Jan 1970
    Location
    Brisbane, Queensland
    Posts
    5,362

    Sudden Powerloss on Take-off

    I fitted an EGR blanking plate to my wife’s car which has the 2.0 version of that same PSA motor. That had a problem that was also EGR related. I also used induction cleaner.

    I would try some induction cleaner like Revive.

    Revive Engine Cleaner & Power Restorer Starter Kit Petrol Diesel Turbo NAS *NEW | eBay
    L322 tdv8 poverty pack - wow
    Perentie 110 wagon ARN 49-107 (probably selling) turbo, p/steer, RFSV front axle/trutrack, HF, gullwing windows, double jerrys etc.
    Perentie 110 wagon ARN 48-699 another project
    Track Trailer ARN 200-117
    REMLR # 137

  3. #3
    Join Date
    Mar 2019
    Location
    Brisbane south side
    Posts
    27
    Get a new Genuine Crank Angle Sensor.
    10 minutes to replace.
    Do not get an aftermarket one.

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!