Results 1 to 8 of 8

Thread: Steering rods hitting leaf springs

  1. #1
    Join Date
    Feb 2018
    Location
    Adelaide
    Posts
    74

    Steering rods hitting leaf springs

    Gíday all.
    Are the lead springs on early series 2 particular to a type of swivel hub housing ? Iíve replaced upper steering arm to lower steering arm swivel housing and steering arms but my newly acquired steering rods now hit the leaf springs. The swivel and steering arms are all from the same donor unit to clarify.


    Itís on both sides. Any ideas ?



    Kim

    'Maggie' 1960 Series 2 88, 2.25 Petrol 3MB

  2. #2
    Join Date
    Jan 1970
    Location
    Central West NSW
    Posts
    23,145
    There is not a lot of clearance at the best of times. You have a track rod that is significantly greater diameter than standard, so losing clearance there. Also, the spring appears to have more than standard camber - is the engine out allowing it to be unloaded? Also, there is the possibility that the shock absorbers are not fitted and these would limit the spring extension to less than what it has at the moment.
    John

    JDNSW
    1986 110 County 3.9 diesel
    1970 2a 109 2.25 petrol

  3. #3
    Join Date
    Feb 2018
    Location
    Adelaide
    Posts
    74
    Gíday. Thanks for the reply. Yeah the shocks arenít fitted nor the engine at the moment. That may well be the issue. Cheers
    Kim

    'Maggie' 1960 Series 2 88, 2.25 Petrol 3MB

  4. #4
    Join Date
    Jul 2011
    Location
    Yarrawonga, Vic
    Posts
    5,706
    John said exactly what I was going to. Those front springs have excessive camber , they should be much flatter that that. (Unless a 6 cylinder Perkins or Cummins is going into it. ) Ditto the track rod is excessively thick , there is no need for heavy duty track rod on a Series as its well up out of the way compared to the Coilers.

  5. #5
    Join Date
    Jul 2011
    Location
    Yarrawonga, Vic
    Posts
    5,706
    as a comparison heres my Series3 with one spring compressed & one relaxed , theres still a good inch from track rod to top of spring


  6. #6
    Join Date
    Feb 2018
    Location
    Adelaide
    Posts
    74
    Thanks all. hopefully with the engine in it should make a difference. Iíve got the standard steering rods as well, Iíll put them in and see how it goes. I appreciate all the responses.
    Kim

    'Maggie' 1960 Series 2 88, 2.25 Petrol 3MB

  7. #7
    Join Date
    Jul 2011
    Location
    Yarrawonga, Vic
    Posts
    5,706
    BTW, what tyres are they? look like Bar Treads , didn't know Kumho made them !

  8. #8
    Join Date
    Feb 2018
    Location
    Adelaide
    Posts
    74
    Quote Originally Posted by goingbush View Post
    BTW, what tyres are they? look like Bar Treads , didn't know Kumho made them !
    Yeah they are the original tyres that I got her with. Probably discontinued by now. They are serving a purpose for the rebuild.
    Kim

    'Maggie' 1960 Series 2 88, 2.25 Petrol 3MB

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Search AULRO.com ONLY!
Search All the Web!